Delay on Email Notifications and After Submit Salesforce Connectors
Incident Report for FormAssembly
Resolved
This incident has been resolved. Notifications and connectors are running as expected.
Posted Mar 06, 2023 - 14:19 EST
Monitoring
We are currently experiencing delays with email notifications and After Submit Salesforce Connectors on Professional and Premier accounts. Remediation efforts have been put in place and we are currently monitoring the issue to ensure improvement.

Note: Delays in AfterSubmit Connectors can be temporarily alleviated by moving the connector from After Submit to Submit in the connector timeline.
Posted Mar 06, 2023 - 10:58 EST
This incident affected: FormAssembly Professional/Premier.