"Something went wrong" error when saving a form with reCAPTCHA
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 23:57 EST
Identified
At approximately 12:50 PM ET on 1/15/25, we began receiving reports of an error displaying when saving forms with reCAPTCHA enabled. Our team is working on resolving the issue.

In the meantime, as a temporary workaround, you can disable reCAPTCHA on your forms to avoid the error. We sincerely apologize for the inconvenience.
Posted Jan 23, 2025 - 10:13 EST
This incident affected: FormAssembly Professional/Premier, FormAssembly Essentials, FormAssembly Team, FormAssembly Basic, FormAssembly Enterprise, FormAssembly Compliance, and FormAssembly Government.