Notifications delayed on a small segment of Enterprise Accounts
Incident Report for FormAssembly
Resolved
This incident has been resolved. These emails will continue to be retried over the course of the next few days.
Posted Apr 10, 2024 - 10:29 EDT
Identified
At approximately 10:10pm EST on 4/5/24, our team identified an issue affecting respondent-related emails (Auto-Responder, E-Signature, Notifications, etc) for a small segment of customers. These respondent emails are currently being delayed by recipient email providers. They will continue to be retried over the course of the next few days.

We will update as more information becomes available.
Posted Apr 09, 2024 - 16:08 EDT
This incident affected: FormAssembly Enterprise.