Inaccessible Forms List and Form Submission Error on Basic, Professional & Premier accounts
Incident Report for FormAssembly
Resolved
The team has identified the issue and implemented a fix. The forms list and individual forms should now be accessible and functioning as expected.
Posted Nov 26, 2024 - 15:04 EST
Investigating
We are investigating reports of forms list not loading and errors when submitting forms. We apologize for any inconvenience and are working to resolve this as quickly as possible. We will continue to update here as more information becomes available.
Posted Nov 26, 2024 - 14:00 EST
This incident affected: FormAssembly Professional/Premier and FormAssembly Basic.