Multiple reCAPTCHAs on Select Forms Published using Server-Side Script and WordPress plugin

Incident Report for FormAssembly

Resolved

The issue causing multiple reCAPTCHA checkboxes to appear on some forms has been resolved. Affected forms are now functioning as expected. We appreciate your patience while our team worked to implement the fix.
Posted Aug 06, 2025 - 13:54 EDT

Update

We are continuing to work on a fix for this issue. Thanks for your patience.
Posted Aug 04, 2025 - 08:32 EDT

Identified

We’re currently aware of an issue where some users who have forms with reCAPTCHA enabled are seeing the CAPTCHA appear multiple times when published using server-side script (REST API) or our WordPress plugin. Our team is actively working on a fix.

As a temporary workaround, you can publish your form using an iFrame. Please refer to the following guides for more information:
https://help.formassembly.com/help/340359-publish-with-an-iframe
https://help.formassembly.com/help/wordpress#publish-with-an-iframe-inline-frame-

We apologize for the inconvenience and will share another update as soon as we have more information.
Posted Aug 01, 2025 - 11:22 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, FormAssembly Basic, FormAssembly Enterprise, and FormAssembly Government.