Compliance, Teams, Essentials, and Enterprise users having trouble accessing forms and logging in
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted May 31, 2023 - 17:21 EDT
Monitoring
A fix has been implemented for this issue and the team will continue to monitor the results.
Posted May 31, 2023 - 16:52 EDT
Update
We are continuing to work toward a fix for this issue.

Please note that this issue is intermittently affecting the Support Request Form. If your support request does not send as expected, please email us directly at support@formassembly.com
Posted May 31, 2023 - 15:43 EDT
Identified
This issue has been identified as related to a time-out issue as reported by our vendor https://status.salesforce.com/incidents/11197. We will continue to monitor the incident for next steps.
Posted May 31, 2023 - 14:25 EDT
Investigating
At approximately 1:10 PM EST on May 31, 2023, our team became aware of an issue with some Compliance, Teams, Essentials, and Enterprise users having trouble accessing forms and logging in. For updates, please monitor this page.
Posted May 31, 2023 - 13:38 EDT
This incident affected: FormAssembly Enterprise and FormAssembly Compliance.