Reports of inaccessible forms and accounts on Team & Enterprise Accounts

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Sep 25, 2023 - 14:23 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2023 - 11:14 EDT

Investigating

Our team is currently investigating reports of inaccessible forms and accounts on select Team accounts. We will continue to update here as new information is identified.
Posted Sep 25, 2023 - 10:45 EDT
This incident affected: FormAssembly Team.