Reports of slow loading forms on US-based Enterprise accounts

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Aug 19, 2022 - 09:40 EDT

Monitoring

A fix has been implemented and we will be monitoring results through the evening.
Posted Aug 18, 2022 - 20:22 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 18, 2022 - 19:10 EDT

Update

We continue to investigate and monitor the situation.
Posted Aug 18, 2022 - 18:48 EDT

Investigating

At approximately 4pm ET our team began receiving reports of forms loading slowly across US-based Enterprise accounts. We are actively investigating the issue and will update here with more details as they become available.
Posted Aug 18, 2022 - 17:45 EDT
This incident affected: FormAssembly Enterprise.