Notifications Not Getting Triggered on a small segment of Enterprise Accounts
Incident Report for FormAssembly
Resolved
Requests for removal from all affected lists have been completed and are rolling out. We will continue to monitor over the coming days.
Posted Feb 14, 2024 - 11:55 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 14, 2024 - 07:44 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2024 - 17:02 EST
Identified
At approximately 1:27pm EST on 2/12/24, our team identified an issue affecting respondent-related emails (Auto-Responder, E-Signature, Notifications, etc) for a small segment of customers. Some common 'freemium' email service providers are blocking these emails from being received.

We will update as more information becomes available.
Posted Feb 13, 2024 - 16:51 EST
This incident affected: FormAssembly Enterprise and FormAssembly Compliance.