Inaccessible account and Forms on Team, Essential & legacy Enterprise accounts

Incident Report for FormAssembly

Resolved

A fix has been implemented and accounts should be operating as expected. If you continue to run into any issues, please reach out to support with more details.
Posted Mar 22, 2024 - 10:25 EDT

Investigating

Our team is currently investigating reports of inaccessible account with errors on Team, Essential & legacy Enterprise accounts.
Posted Mar 22, 2024 - 10:11 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, and FormAssembly Enterprise.