Inaccessible Forms List on Basic, Professional & Premier accounts

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 14:40 EST

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Dec 03, 2025 - 14:24 EST

Investigating

We’re currently investigating reports of the Forms List not loading. Our apologies for the inconvenience. Our team is working to resolve this as quickly as possible. We’ll continue to share updates here as soon as more information becomes available.
Posted Dec 03, 2025 - 13:31 EST
This incident affected: FormAssembly Professional/Premier and FormAssembly Basic.