Microsoft Excel and Sharepoint Connector Reconnection Issue

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 15:22 EST

Monitoring

A fix has been implemented. Existing authorizations should now function as expected. If you’re still seeing an error, please re-authenticate the connector.
Posted Feb 12, 2026 - 14:55 EST

Investigating

We are currently investigating an issue impacting Microsoft Excel and Sharepoint connectors on the platform.

At this time, customers who encounter connector errors are unable to successfully reconnect to Microsoft. Once the error appears, reconnection attempts are failing, and affected connectors remain blocked.

Our team is actively working to identify the root cause and restore reconnection functionality as quickly as possible.

We will provide updates here as soon as more information becomes available.
Posted Feb 12, 2026 - 14:10 EST