US Teams and Enterprise accounts inaccessible

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Jun 27, 2023 - 18:59 EDT

Monitoring

At approximately 5:10pm EST the team identified an issue with a segment of US based Enterprise and Teams accounts there were not accessible via form or account. At approximately 5:21 pm EST a fix was initiated. Our team will continue to monitor the situation.
Posted Jun 27, 2023 - 18:00 EDT
This incident affected: FormAssembly Essentials and FormAssembly Team.