Delay in Salesforce Connectors and Email Notifications on Professional and Premier Plans

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Dec 15, 2022 - 09:16 EST

Monitoring

Our team has identified the source of the issue and implemented a fix to bring the forms back up to the expected speed. We are currently monitoring the situation to confirm.
Posted Dec 14, 2022 - 17:43 EST

Investigating

We are currently investigating reports of delays in information being sent via Salesforce Connector and on Email Notifications. We will share additional details as they become available.
Posted Dec 14, 2022 - 15:46 EST
This incident affected: FormAssembly Professional/Premier.