Brief Interruption of Compliance Cloud Services
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Jun 23, 2021 - 17:32 EDT
Investigating
RESOLVED
Beginning shortly after 5:00 PM Eastern Standard Time for approximately 10 minutes, Compliance Cloud accounts based on Frankfurt and Montreal servers reported a brief interruption of services. Our systems team is currently reviewing the incident for root cause.
Posted Jun 23, 2021 - 17:31 EDT
This incident affected: FormAssembly Compliance.