Delayed Email Notifications and After Submit Salesforce Connectors on Professional and Premier Plans
Incident Report for FormAssembly
Resolved
This incident has been resolved. Notifications and After Submit Salesforce connectors are running as expected.
Posted Mar 08, 2023 - 17:38 EST
Monitoring
At approximately 11:30 am EST on March 8th, customers on Professional and Premier accounts started to experience delays with email notifications and After Submit Salesforce Connectors. Remediation efforts have been put in place and we are currently monitoring the issue to ensure improvement.

Note: Delays in After Submit Connectors can be temporarily alleviated by moving the connector from After Submit to Submit in the connector timeline.
Posted Mar 08, 2023 - 16:19 EST
This incident affected: Salesforce (Salesforce Connector) and FormAssembly Professional/Premier, Emails.