Reports of Slow Load Times on Team Accounts

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 10:08 EDT

Monitoring

A fix has been implemented, and performance has returned to normal levels.
This incident was resolved as of 6:30 PM ET on April 22.
Posted Apr 22, 2025 - 18:30 EDT

Investigating

At approximately 9:50 AM ET, we began receiving reports of slowness affecting the application and forms for Team Plan accounts. Our team is actively investigating the issue. We will update this page as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted Apr 22, 2025 - 16:54 EDT
This incident affected: FormAssembly Team.