Email Notifications Not Being Sent

Incident Report for FormAssembly

Resolved

A fix has been implemented, and email notifications should now be sending as expected. Affected responses may need to be reprocessed to trigger the email notifications. https://help.formassembly.com/help/responses#reprocess-a-response
Posted Apr 30, 2025 - 17:05 EDT

Identified

We are currently investigating an issue where email notifications on forms are not being sent as expected. The issue started on April 30 at approximately 11:58 AM ET. Our team is actively working on a resolution. We will continue to provide updates on this page as more information becomes available.
Posted Apr 30, 2025 - 15:20 EDT
This incident affected: FormAssembly Professional/Premier, FormAssembly Essentials, FormAssembly Team, FormAssembly Basic, FormAssembly Enterprise, FormAssembly Compliance, FormAssembly Government, and Emails.