Some Accounts Reporting Issues with Admin Dashboard & Forms
Incident Report for FormAssembly
Resolved
This incident has been resolved, and functionality has been restored to forms, workflows, and the Admin Dashboard.

If you experience any further issues, please contact our support team at support@formassembly.com
Posted Oct 02, 2024 - 13:55 EDT
Update
We are actively working on a fix for this issue.
Posted Oct 02, 2024 - 13:15 EDT
Identified
At approximately 1:00 pm EST, our team identified an issue in which the Admin Dashboard cannot be accessed, as well as some forms and workflows.

Our primary support form is also being affected by this issue. Please monitor this page and/or reach out to support@formassembly.com for direct assistance in the meantime.
Posted Oct 02, 2024 - 13:12 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, FormAssembly Enterprise, and FormAssembly Government.