Form-Level Salesforce Connector and Email Notifications Not Processing Upon Submission

Incident Report for FormAssembly

Monitoring

We’ve mitigated the processing delays affecting Salesforce connector submissions and form notifications. Processing has returned to normal, and affected submissions and notifications should now be going through as expected.

Clarification: This was a processing delay, not a failure. Affected submissions and notifications were queued and should complete automatically without needing to be reprocessed.

Potential duplicate records: If you manually reprocessed a submission while it was delayed, you may see a duplicate record in Salesforce—one from the original submission and one from the reprocessing attempt. We recommend reviewing recently reprocessed submissions for duplicates.
Posted Aug 18, 2026 - 14:49 EDT

Update

We are continuing to investigate the issue.
Posted Aug 18, 2026 - 13:35 EDT

Investigating

We are investigating reports that the form-level Salesforce connector and form notifications are not processing upon form submission for a subset of accounts.

We are actively investigating and will provide updates as more information becomes available.
Posted Aug 18, 2026 - 12:03 EDT
This incident affects: Salesforce (Salesforce Connector) and Emails.