Admin Dashboard & Form Builder not accessible

Incident Report for FormAssembly

Resolved

A fix has been implemented. The Admin Dashboard, Builder, and connectors are now accessible.
The incident has been resolved.
Posted Oct 06, 2025 - 12:19 EDT

Identified

Our team has identified the issue affecting the Admin dashboard, Builder and Locked connectors. They are currently working on a fix for the issue. We will continue to update here as more information becomes available and a fix is issued.
Posted Oct 06, 2025 - 10:30 EDT

Investigating

We are currently investigating reports that are impacting FormAssembly, such as access to the Admin Dashboard and Form Builder for account admins. Our engineering team is actively investigating and working to resolve this as quickly as possible. We will continue to post here as more information is available.
Posted Oct 06, 2025 - 08:56 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, FormAssembly Basic, FormAssembly Enterprise, FormAssembly Compliance, and FormAssembly Government.