Forms currently unavailable on Professional and Premier accounts.
Incident Report for FormAssembly
Resolved
This issue has been resolved and all forms are up and running as expected. Our team will continue to research why the recently updated certificate was invalidated to help avoid future occurrences.
Posted Jun 15, 2021 - 10:14 EDT
Investigating
Our team is currently investigating reports of forms being unavailable on Professional and Premier accounts due to an invalid certificate. We will be in touch shortly with more details.
Posted Jun 15, 2021 - 09:04 EDT
This incident affected: FormAssembly Professional/Premier.