Some Form Submissions Not Redirecting Properly

Incident Report for FormAssembly

Identified

We have identified the cause of the issue impacting form submission redirects.

Our engineering team is actively working on a fix, which will be implemented as soon as possible. We will continue to provide updates here as progress is made.
Posted Feb 02, 2026 - 15:58 EST

Investigating

We are currently investigating an issue where some form submissions are not redirecting respondents as expected after submission.

Under normal circumstances, respondents are redirected back to the form if there is a validation or connector error, allowing them to correct their information and resubmit. If no errors occur, respondents are redirected to the configured thank-you page or redirect URL.

Some submissions may remain on the response processing page and display a default confirmation message instead of submissions displaying potential errors.

Our team is actively investigating the root cause of this issue. We will continue to post updates here as more information becomes available.
Posted Feb 02, 2026 - 15:27 EST