SAML-Authenticated Forms Not Loading for Some Accounts

Incident Report for FormAssembly

Resolved

This incident was resolved at 3:35 PM ET. Thank you for your patience while we worked on a fix.
Posted Sep 17, 2025 - 17:02 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Sep 17, 2025 - 15:46 EDT

Update

We are continuing to work toward a fix for this issue. We'll continue to update here as we have more details.
Posted Sep 17, 2025 - 11:53 EDT

Identified

We are investigating an issue affecting a subset of accounts where forms using SAML authentication fail to load. Respondents may encounter an infinite loading screen when attempting to access these forms.

Our team is actively working to identify the root cause and resolve the issue.

We apologize for the disruption this has caused. We will provide updates here as more information becomes available.
Posted Sep 16, 2025 - 16:56 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, FormAssembly Enterprise, FormAssembly Compliance, and FormAssembly Government.