Enterprise Customers: Intermittent Errors when Saving or Submitting Updates to Saved Responses
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Jun 03, 2022 - 17:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2022 - 14:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2022 - 10:54 EDT
Identified
Our team identified an intermittent issue for form respondents who have saved form responses before May 31st. The error says "Something went wrong..." and appears when a respondent saves or submits a previously saved response. Our product and engineering teams are actively reviewing remediation solutions to this error. Please check back for updates on this issue.

In the meantime, as a form creator, you may be able to run through these steps to fix the issue.

• Find the Response in the Response page
• View the Response and choose to Finalize it
• Once Finalized, choose to Reopen the response and send an email to the respondent asking them to make the necessary updates to their response without any issues

Important: Please note that finalizing a response will run your enabled form connectors and email notifications.
Posted Jun 02, 2022 - 19:30 EDT
This incident affected: FormAssembly Enterprise.