Form Submission Issues on Professional and Premier Accounts and US based Enterprise Instances
Incident Report for FormAssembly
Resolved
This incident has now been resolved. Please contact our support team if you continue to run into any issues.
Posted Dec 07, 2021 - 19:26 EST
Monitoring
Our team continues to monitor the situation and await a resolution.

Please review the Status Page for AWS for more details.

https://status.aws.amazon.com/
Posted Dec 07, 2021 - 18:19 EST
Investigating
AWS, our application management service, confirmed an operational issue that is intermittently affecting Encryption & Decryption of sensitive data fields in FormAssembly. This may cause issues for form submissions that have sensitive data fields. We will continue to monitor this issue and post updates as we receive them.

Please review the Status Page for AWS for more details.

https://status.aws.amazon.com/
Posted Dec 07, 2021 - 11:56 EST
This incident affected: FormAssembly Professional/Premier, FormAssembly Enterprise, and FormAssembly Compliance.