Notifications not getting triggered on Basic/Professional/Premier accounts
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 14:12 EST
Identified
Our team has identified an issue affecting respondent-related emails (Auto-Responder, E-Signature, Notifications, etc) for Basic/Professional/Premier accounts. Some common 'freemium' email service providers are blocking these emails from being received.

We will update as more information becomes available.
Posted Mar 05, 2024 - 09:09 EST
This incident affected: FormAssembly Professional/Premier and FormAssembly Basic.