Inaccessible Form Lists – Frankfurt Region

Incident Report for FormAssembly

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 11:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 11:18 EDT

Investigating

We are investigating reports of inaccessible form lists affecting accounts in the Frankfurt region. We understand the disruption this may cause and are actively working to resolve it as quickly as possible. We will provide updates as more information becomes available.
Posted Mar 26, 2026 - 10:50 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, FormAssembly Enterprise, and FormAssembly Compliance.