Form-level Salesforce Connector and Email Notifications Delayed Processing on Submission

Incident Report for FormAssembly

Resolved

Delayed Salesforce Connector and Email Notification Processing on Form Submission has been resolved.

Both the Salesforce Connector and email notifications are now running as expected.

We apologize for any inconvenience caused and appreciate your patience.

If you continue to experience issues, please contact support.
Posted Aug 13, 2026 - 22:08 EDT

Monitoring

We identified a period of increased submission volume that resulted in delayed connector and email notification processing. The increased activity has subsided, and processing queues have now caught up.

We have not identified any broader service issues and will continue to monitor the situation.
Posted Aug 13, 2026 - 18:09 EDT

Investigating

We are currently investigating reports that the form-level Salesforce connector and form notifications are experiencing delayed processing upon form submission for some accounts.

Our team is actively investigating the issue and will share additional updates as our investigation progresses.

Update: Further investigation shows this is a delay in processing rather than a failure to process.
Posted Aug 13, 2026 - 16:54 EDT
This incident affected: Salesforce (Salesforce Connector).