Forms & Form List unavailable on select accounts
Incident Report for FormAssembly
Resolved
This incident has now been resolved. Our team will continue to monitor the issue.
Posted May 09, 2023 - 09:48 EDT
Identified
Our team has identified an issue with the forms list and select forms being unavailable across a segment of Essential and Team accounts. A fix has been implemented and should be effective shortly. We will continue to update here as available.
Posted May 09, 2023 - 09:12 EDT
This incident affected: FormAssembly Enterprise and FormAssembly Compliance.