AWS error message 'Error executing "GetParameters" reported on forms with sensitive data fields
Incident Report for FormAssembly
Resolved
According to AWS, the issue was resolved at 10:45 AM PDT, when error rates and latencies returned to normal levels. The issue has been resolved and the service is operating normally.

Please let us know if you continue to run into any concerns.
Posted Sep 09, 2022 - 14:56 EDT
Monitoring
Our team is aware of an ongoing issue with AWS resulting in errors on forms that include sensitive data fields. Our team is currently monitoring the status at https://health.aws.amazon.com/health/status and we will update here with more details as they become available.
Posted Sep 09, 2022 - 12:29 EDT
This incident affected: FormAssembly Professional/Premier, FormAssembly Enterprise, and FormAssembly Compliance.