Form-level Salesforce Connector and Email Notifications Delayed Processing on Submission

Incident Report for FormAssembly

Resolved

The delayed processing affecting email notifications and Salesforce connectors has been resolved.

Affected submissions were processed successfully after a delay. We’ve confirmed that both notifications and connectors are now processing normally.
Posted Aug 28, 2026 - 13:31 EDT

Investigating

We are currently investigating reports of delayed processing affecting the form-level Salesforce connector and form notifications after form submission for some accounts.

We apologize for any inconvenience this may be causing.

We will provide updates as more information becomes available.
Posted Aug 28, 2026 - 13:00 EDT
This incident affected: Salesforce (Salesforce Connector) and Emails.