Intermittent Loading Issues on app.formassembly.com and tfaforms.com
Incident Report for FormAssembly
Resolved
As of 4:36pm ET, FormAssembly users and respondents should now see normal performance on app.formassembly.com and tfaforms.com. We will continue to monitor the situation.
Posted Nov 15, 2019 - 18:55 EST
Monitoring
As of 4:36pm ET, FormAssembly users and respondents should now see normal performance on app.formassembly.com and tfaforms.com. Our team is continuing to monitor the situation.

Please contact support@formassembly.com with further questions and concerns.
Posted Nov 15, 2019 - 16:40 EST
Update
We are continuing to investigate degraded performance on app.formassembly.com and tfaforms.com. Please contact support@formassembly.com with questions and concerns.
Posted Nov 15, 2019 - 16:11 EST
Investigating
We are currently investigating degraded loading performance affecting app.formassembly.com and tfaforms.net beginning around 2:45pm ET. This may result in issues with logging in and using FormAssembly for Professional and Premier accounts. Additionally, respondents may experience form loading issues when attempting to view and submit forms on tfaforms.com.

Please contact support@formassembly.com with questions and concerns.
Posted Nov 15, 2019 - 15:22 EST
This incident affected: FormAssembly Professional/Premier.