Salesforce Marketing Cloud Connectors Unavailable

Incident Report for FormAssembly

Resolved

This incident has been resolved. We identified and corrected the underlying issue, and Salesforce Marketing Cloud (SFMC) Prefill and Submit connectors are now loading and operating as expected. Affected forms are accessible again.

Please note that a subset of responses submitted between 9:20 AM and 1:20 PM ET on August 19, 2026 may not have been sent to Salesforce Marketing Cloud and may need to be manually reprocessed. We recommend reviewing responses submitted during this window and reprocessing any that did not sync as expected.

Thank you for your patience.
Posted Aug 19, 2026 - 13:41 EDT

Monitoring

We've identified the cause of the issue affecting Salesforce Marketing Cloud (SFMC) Prefill and Submit connectors and have applied a fix. Connector configurations should now be loading normally, and affected forms should be accessible again. We're monitoring closely to confirm full recovery.
Posted Aug 19, 2026 - 13:26 EDT

Investigating

We're investigating reports that Salesforce Marketing Cloud (SFMC) Prefill and Submit connector configurations are not loading. Forms that use the SFMC Prefill connector may currently be inaccessible. Our team is actively looking into the cause, and we'll share an update shortly.
Posted Aug 19, 2026 - 13:12 EDT
This incident affected: Salesforce (Salesforce Marketing Cloud Connector).