Datasets Not Responding/Uploading

Incident Report for FormAssembly

Resolved

This incident has now been resolved.
Posted Sep 30, 2021 - 18:31 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 30, 2021 - 17:33 EDT

Update

We are continuing to investigate this issue.
Posted Sep 30, 2021 - 17:03 EDT

Investigating

We are currently investigating reports of datasets not displaying or uploading to forms as expected on Professional and Premier accounts.
Posted Sep 30, 2021 - 17:02 EDT
This incident affected: FormAssembly Professional/Premier.