FormAssembly forms currently unavailable on small segment of Compliance, Teams, Essentials & Enterprise accounts
Incident Report for FormAssembly
Resolved
This incident was resolved at approximately 1:35PM ET. Our team is currently compiling complete details to be shared, please reach out to your CSM if you are interested in receiving more information.

Our team will continue to monitor the situation as we explore long-term solutions to avoid future incidents.
Posted Apr 12, 2023 - 12:56 EDT
Monitoring
An initial fix for this issue has been implemented, and we continue monitoring the situation.
Posted Apr 12, 2023 - 12:08 EDT
Identified
At approximately 11:20 am ET, our team became aware of reports of inaccessible forms on a small segment of Essential, Team & Enterprise accounts. Remediation efforts are being prepared to ensure improvement. Updates will be provided here as available.
Posted Apr 12, 2023 - 11:39 EDT
This incident affected: FormAssembly Enterprise.