Intermittent Email Notifications and Salesforce Connector Issues

Incident Report for FormAssembly

Resolved

This incident has been resolved.

While improving our search engine optimization, we ran into an unforeseen issue that caused the Submit Salesforce Connector to intermittently not send email notifications or process, log, and send response information to Salesforce. The issue began on Monday, June 7th, at approximately 1:00 PM ET. We partially resolved the issue on June 8th at 3:45 PM ET and fixed the underlying cause on June 10th at 2 PM ET.
Posted Jun 09, 2021 - 12:25 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Jun 08, 2021 - 18:42 EDT

Identified

The issue has been identified, and a fix is being implemented.
Posted Jun 08, 2021 - 16:19 EDT

Investigating

We are investigating customer reports of intermittent issues of incomplete Salesforce Connector submissions sent to Salesforce and unsent Email Notification.
Posted Jun 08, 2021 - 15:54 EDT
This incident affected: FormAssembly Professional/Premier and FormAssembly Enterprise.