AWS Intermittent Issues with European Services
Incident Report for FormAssembly
Resolved
AWS has resolved this issue.
Posted Aug 25, 2020 - 09:13 EDT
Monitoring
Amazon Web Services is having intermittent issues with their European services that may also affect FormAssembly Enterprise Cloud customers located in EMEA. Please note, AWS is a service FormAssembly utilizes for data storage and infrastructure. While the underlying issue lies with AWS, FormAssembly is closely monitoring the issue.

Updates can also be monitored on the AWS Status page:

https://status.aws.amazon.com/
Posted Aug 25, 2020 - 07:35 EDT
This incident affected: FormAssembly Enterprise.