Delayed Email Notifications & After Submit Connectors on Team Accounts
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 15:23 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2023 - 12:36 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 03, 2023 - 11:52 EDT
Investigating
At approximately 2pm EST on November 2, 2023, our team became aware of an issue pertaining to delayed email notifications & after submit connectors on Team Accounts. For updates, please monitor this page or contact support. Please write "Delayed Email Notifications" in the “Short Description” field for the quickest response.
Posted Nov 03, 2023 - 11:03 EDT
This incident affected: FormAssembly Team.