Issues with embedded forms in Google Chrome
Incident Report for FormAssembly
Resolved
Our team has confirmed internally and with several customers that setting a compatible Referrer Policy for the parent page of an embedded form will prevent issues with form rendering and response submission in Google Chrome 85.
Posted Oct 06, 2020 - 13:23 EDT
Identified
Our team has identified the issue as being related to new default Referrer Policy behavior in Google Chrome 85. This issue can be rectified by defining a compatible Referrer Policy for pages with FormAssembly forms embedded on them; such as no-referrer-when-downgrade which was the previous default policy for pages where no Referrer Policy was defined.

Inserting the following <meta> tag anywhere on the page, preceding the form, will allow forms to function properly:

<meta name="referrer" content="no-referrer-when-downgrade">

It is recommended that meta tags be added to <head>. It is possible to add the <meta> tag to all forms using Advanced Branding to include it in the form <head>. The <meta> tag can also be added to the Custom Code section of a form.

Note: This will override any Referrer Policy you may have set for your pages. If you have set a specific policy other than "no-referrer-when-downgrade", please review the following document for any potential impact this may have: MDN web docs: Referrer Policy
Posted Oct 02, 2020 - 16:27 EDT
Investigating
We are investigating reports from customers related to recent changes in Google Chrome that may be negatively impacting embedded forms.
Posted Oct 01, 2020 - 18:38 EDT