Delayed email notifications on Professional and Premier Plans

Incident Report for FormAssembly

Resolved

This incident has been resolved and notifications are receiving normally at this time. This issue also caused Salesforce After Submit connectors to run delayed but they are also running normally at this time.
Posted Dec 01, 2022 - 09:24 EST

Investigating

Our team is currently investigating reports of delayed email notifications on Professional and Premier Plans.
Posted Nov 30, 2022 - 22:48 EST
This incident affected: FormAssembly Professional/Premier.