Enterprise Cloud service disruption
Incident Report for FormAssembly
Resolved
All issues have been resolved and all services are operating normally. We apologize for any inconvenience this may have caused.
Posted over 1 year ago. Jul 21, 2017 - 17:14 EDT
Identified
We have identified the issue with one of our backend database servers, we are working on fixing it.
Posted over 1 year ago. Jul 21, 2017 - 17:08 EDT
Investigating
We're experiencing an elevated level of errors and service failures on Enterprise Cloud, we are currently looking into the issue.
Posted over 1 year ago. Jul 21, 2017 - 17:05 EDT