App.formassembly.com Errors
Incident Report for FormAssembly
Resolved
All issues are resolved now. All services are normal.
Posted 10 months ago. Oct 27, 2017 - 12:52 EDT
Investigating
We're experiencing an elevated level of errors on Professional and Premier accounts are currently looking into the issue. Enterprise and Compliance Cloud clients are not affected by this.
Posted 10 months ago. Oct 27, 2017 - 12:31 EDT