Professional and Premier plan customers using FormAssembly for AppExchange unable to review forms and response data
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 11:28 EDT
Monitoring
A fix has been implemented as of 3:17 p.m. ET and we are monitoring the situation.
Posted Mar 20, 2020 - 15:35 EDT
Identified
We have identified the issue and are currently preparing a solution. Published forms are not affected.
Posted Mar 20, 2020 - 14:37 EDT
Investigating
We are currently investigating reports of some customers that are unable to access FormAssembly using the AppExchange app for Salesforce. Professional and Premier customers can still login by going to FormAssembly.com and using the Login link at the top of the page.
Posted Mar 20, 2020 - 12:57 EDT
This incident affected: FormAssembly Professional/Premier.