Processing Delays - Systems Degraded Performance
Incident Report for FormAssembly
Resolved
All issues have been resolved, all services are functioning normally now.
Posted 10 months ago. Jun 26, 2017 - 13:31 EDT
Identified
Our data processing infrastructure for app.formassembly.com is running behind which is causing processing delays. No data has been lost and the system should recover shortly.
Posted 10 months ago. Jun 26, 2017 - 13:17 EDT