Reports of inaccessible forms and accounts on a small segment US based Team, Essential, Enterprise & Compliance accounts.
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 14:57 EDT
Update
We are continuing to monitor until completely resolved.
Posted Apr 15, 2024 - 14:43 EDT
Monitoring
A fix has been implemented and we are continuing to monitor the accounts as they come back online.

The Support form should now be accessible as needed.
Posted Apr 15, 2024 - 12:51 EDT
Investigating
Our team is currently investigating reports of inaccessible accounts and forms on a small subset of US based Team, Essential, Enterprise & Compliance accounts.

This also affects our Support form for reporting new cases. If you are unable to reach the support form, please email us directly at help@formassembly.com
Posted Apr 15, 2024 - 12:30 EDT
This incident affected: FormAssembly Essentials, FormAssembly Team, FormAssembly Enterprise, and FormAssembly Compliance.