Processing Delays - Systems Degraded Performance
Incident Report for FormAssembly
Resolved
All issues have been resolved, all services are functioning normally now.
Posted 5 months ago. Jul 03, 2017 - 13:34 EDT
Investigating
Our data processing infrastructure for app.formassembly.com is running behind which is causing processing delays. No data has been lost and the system should recover shortly.
Posted 5 months ago. Jul 03, 2017 - 12:46 EDT