Elevated Dashboard Errors
Incident Report for FormAssembly
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 20, 2017 - 18:07 EDT
Identified
We're experiencing an elevated level of errors when admin users try to add new users or view all users within the dashboard. We have identified the issue and will be deploying a fix shortly.
Posted about 1 month ago. Oct 20, 2017 - 18:03 EDT