[RESOLVED] Pro/Premier plans - Response Processing Offline at 2:55 PM EST 2018/12/17
Incident Report for FormAssembly
Resolved
Pro/Premier: FormAssembly's response processing was offline intermittently for ~15 min at 2:55 PM EST. Responses submitted during that time were not stored.

We know your data is important to you, and we strive to prevent these outages. We will be putting new procedures in place to prevent this issue from occurring in the future. If you have any concerns, please feel free to contact us at support@formassembly.com.
Posted about 1 month ago. Dec 17, 2018 - 17:44 EST
This incident affected: FormAssembly App.